Can not get Edge to listen to localhost on co-located headless vm


I am following the docs to attempt to get Edge and Stream running on a single host. Steam deploys and listens on but Edge will only listen on This is a headless VM so I can not get to the GUI locally to continue following the docs process.

ubuntu@cribl:/opt/cribl-edge/default/cribl$ netstat -nlp
(Not all processes could be identified, non-owned process info
 will not be shown, you would have to be root to see it all.)
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 *               LISTEN      -
tcp        0      0*               LISTEN      -
tcp        0      0    *               LISTEN      -
tcp        0      0  *               LISTEN      -
tcp6       0      0 :::22                   :::*                    LISTEN      -
ubuntu@cribl:/opt/cribl-edge/default/cribl$ cat cribl.yml
  port: 9420
  disabled: false
  loginRateLimit: 2/second
  type: local
ubuntu@cribl:/opt/cribl-edge/default/cribl$ cat /opt/cribl/default/cribl/cribl.yml
  port: 9000
  disabled: false
  loginRateLimit: 2/second
  type: local

Any suggestions please or do I have to put nginx on as a proxy to get both sites working?

Hi @kane.kennedy, you can set the CRIBL_EDGE environment variable to any value to bind to instead of the address.

Or when you start the Cribl Edge from the CLI, ensure you pass in the -H parameter.

Something else to note… if you connect your Edge node to a leader, it will automatically update the binding IP address to the one configured in the Fleet Settings. You will need to change this to if you want the Edge Node to always listen on all IP addresses.

@bdalpe Thank you,

The env variable on it’s own didn’t solve the issue but it did in combination with swapping to mode-edge, starting and stopping Cribl.

I thing the docs on Installing Cribl Edge on Linux | Cribl Docs are incorrect and should tell you to deploy as mode-edge not mode-managed-edge.

Upwards and onwards into getting data in and out next.

Thanks again


In the single instance section the docs rightly specify readers to use mode-edge. In the section following that the docs state to use mode-managed-edge given the assumption that you’d want your Edge nodes to be communicating with your leader node just like your existing worker nodes. The mode is predicated on whether you want it to be managed from the leader node, not whether it’s going to be on the same host as Stream.