Cribl Edge Docker In Managed Mode Issues

Hi,
Running edge in a docker and I can’t seem to get the setting right to report into as an Edge Node. Its reporting to the leader as another Worker.

version: '3.5'


services:
  leader:
    image: ${CRIBL_IMAGE:-cribl/cribl:latest}
    environment:
      - CRIBL_DIST_MODE=master
      - CRIBL_DIST_MASTER_URL=tcp://criblmaster@0.0.0.0:4200
      - CRIBL_VOLUME_DIR=/opt/cribl/config-volume
    ports:
      - "19000:9000"
      - "4200:4200"
    container_name: cribl_leader
    hostname: leader
    volumes:
      - /share/homes/mydir/cribl:/opt/cribl/config-volume
  workers:
    image: ${CRIBL_IMAGE:-cribl/cribl:latest}
    depends_on: 
      - leader
    hostname: cribl_worker
    container_name: cribl_worker
    environment:
      - CRIBL_DIST_MODE=worker
      - CRIBL_DIST_MASTER_URL=tcp://criblmaster@leader:4200
    ports:
      - 9000
       
  edge: 
    image: ${CRIBL_IMAGE:-cribl/cribl:latest}
    depends_on: 
      - leader
    restart: unless-stopped
    ports:
     - 9000
     - 9420
    hostname: cribl_edge
    container_name: cribl_edge
    privileged: true
    #[HOST:CONTAINER]
    volumes:
       - /var/run/appscope:/var/run/appscope
       - /var/run/docker.sock:/var/run/docker.sock
       - /:/hostfs:ro
    environment:
      - CRIBL_DST_MODE=managed-edge
      - CRIBL_DIST_MASTER_URL=tcp://criblmaster@leader:4200?group=default_fleet
    
    

I tried multiple settings to no avail. Any ideas? Thanks Chris

Hi @chrisboy68, I noticed you have a typo in the environment section for the Edge service. Try changing CRIBL_DST_MODE to CRIBL_DIST_MODE and then your Edge node will be correctly associated with the default_fleet.

Oh my goodness! Thank you. I’m up.