Database collector issue

I am testing out the database collector in v4.0 (cannot choose v4 in the form for creating a new topic) and running into an issue. Some of this is documented in Slack but I wanted to bring it here as well. I cannot get a connection to an MSSQL server using an Microsoft Domain account (AD). For security reasons, we do not use SQL accounts, we use service accounts created in our active directory domain. I have tried DOMAIN\user in the “User ID” option in the Connection String but it does not work. Without this feature then this collector option is not going to be used. Can someone shed some light on this?

Hi rolltidega,
Thanks for your patience.
I haven’t worked with MSSQL DB’s via Microsoft Domain accounts previously, so bear with me. I’m assuming the SQL Server is on a remote machine? Linux or Windows? Are the proper permissions in place for the user accounts?
I came across some links that talk through some scenarios of how to go about setting this up, these might be of use:

  1. https://learn.microsoft.com/en-us/sql/linux/sql-server-linux-active-directory-auth-overview?view=sql-server-ver16
  2. https://learn.microsoft.com/en-us/answers/questions/131424/how-to-add-active-directory-user-group-as-login-in.html