How can I add Humio as an Elasticsearch destination?

I believe I correctly added Humio as an Elasticsearch destination, it’s showing as healthy (green check in my screenshot). However when I test it, I get the error “Error: Send failed: SyntaxError: Unexpected token < in JSON at position 0, status: Sender is blocked
Details: undefined” Not sure what I’m doing wrong, any suggestions?

1 UpGoat

Humio Elasticsearch does not support discovery of the Elastic version. By default, Cribl Stream will attempt to discover the Elasticsearch version. You can disable this under the Cribl Stream Elasticsearch destination under the Advanced Settings. Set the Elasticsearch version to 7.X and the error will resolve.

Humio recommends using HEC for better scalability. See this blog post by Cribl SE Alex Cain for more info on how to set Cribl Stream with Humio.

1 UpGoat